acme.sh报错zerossl处理方法

一直使用acme.sh自动更新Let’sencrypt的证书,今日突然发现证书过期了,遂查看问题原因,发现各项设置均为发生更改,但是使用–debug 2参数报错如下:

图片[1]|acme.sh报错zerossl处理方法|leon的博客

刚开始更新了acme.sh:

acme.sh --upgrade

发现依然无效,后又进行更新证书和重新生成新的证书的测试,均报同样的错误:

[Tue Feb 20 16:31:16 CST 2024] get authz objec with invalid status, please try again later.
[Tue Feb 20 16:31:16 CST 2024] _authorizations_seg='https://acme.zerossl.com/v2/DV90/authz/WomymC6Rd5TRFMmr59w1ow'

上网搜寻答案后发现原来是acme.sh将默认CA 证书申请机构从 Let’s Encrypt 转变为 ZeroSSL(详情),而使用ZeroSSL的话需要注册账号才能使用【附使用ZeroSSL的方法(笔者并未实际测试是否可行)】,故只需要将acme.sh默认的申请机构变为 Let’s Encrypt即可:

acme.sh --set-default-ca --server letsencrypt

参考资料:

https://github.com/acmesh-official/acme.sh/wiki/Change-default-CA-to-ZeroSSL

https://blog.ryjer.com/posts/a1993e0126.html

温馨提示:本文最后更新于2024-02-20 17:45:14,已超过56天没有更新。某些文章具有时效性,若文章内容或图片资源有错误或已失效,请联系站长。谢谢!
转载请注明本文链接:https://blog.leonshadow.cn/763482/3222.html
© 版权声明
THE END
喜欢就支持一下吧
点赞15 分享
Leon的博客的头像|leon的博客